<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://wjhnews.com/xmlrpc.php" />

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://wjhnews.com';var et_post_id='12546';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>February 5, 2020 | WJHnews</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WJHnews &raquo; Feed" href="https://wjhnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WJHnews &raquo; Comments Feed" href="https://wjhnews.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wjhnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Divi v.4.2.2" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://wjhnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='awesome-weather-css'  href='https://wjhnews.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.3.2' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-crestafont-css'  href='https://wjhnews.com/wp-content/plugins/cresta-social-share-counter/css/csscfont.min.css?ver=2.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-wp-style-css'  href='https://wjhnews.com/wp-content/plugins/cresta-social-share-counter/css/cresta-wp-css.min.css?ver=2.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-googlefonts-css'  href='//fonts.googleapis.com/css?family=Noto+Sans:400,700&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='pmpro_frontend-css'  href='https://wjhnews.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=2.2.5' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css'  href='https://wjhnews.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=2.2.5' type='text/css' media='print' />
<link rel='stylesheet' id='divi-style-css'  href='https://wjhnews.com/wp-content/themes/Divi/style.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic&#038;ver=5.3.2#038;subset=latin-ext,greek,greek-ext,vietnamese,cyrillic,latin,cyrillic-ext' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='dashicons-css'  href='https://wjhnews.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://wjhnews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://wjhnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://wjhnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"february52020"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://wjhnews.com/wp-content/themes/Divi/core/admin/js/recaptcha.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://wjhnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wjhnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wjhnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='January 29, 2020' href='https://wjhnews.com/january-29-2020/' />
<link rel='next' title='Wednesday February 5, 2020' href='https://wjhnews.com/wednesday-february-5-2020/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://wjhnews.com/february-5-2020/" />
<link rel='shortlink' href='https://wp.me/p5zkGW-3gm' />
<link rel="alternate" type="application/json+oembed" href="https://wjhnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wjhnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F&#038;format=xml" />
<style id='cresta-social-share-counter-inline-css'>.cresta-share-icon .sbutton {font-family: 'Noto Sans', sans-serif;}
			@media (max-width : 640px) {
				#crestashareicon {
					display:none !important;
				}
			}
		#crestashareicon {position:fixed; top:27%; right:0px; float:left;z-index:99;}

		#crestashareicon .sbutton {clear:both;display:none;}
		#crestashareicon .sbutton {float:right;}.cresta-share-icon.first_style .cresta-the-count {left: -11px;}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" /><link rel="shortcut icon" href="https://wjhnews.com/wp-content/uploads/2015/01/site-WJHnews-header.png" /><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<script type="text/javascript">
jQuery( document ).ready(function() {
jQuery(".alignleft a").text("< Earlier News Articles");
jQuery(".alignright a").text("Newer News Articles >");
});
</script><link rel="stylesheet" id="et-divi-customizer-global-cached-inline-styles" href="https://wjhnews.com/wp-content/et-cache/global/et-divi-customizer-global-15801258666211.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-12546 single-format-standard custom-background pmpro-body-has-access et_pb_button_helper_class et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_show_nav et_hide_primary_logo et_secondary_nav_enabled et_secondary_nav_only_menu et_primary_nav_dropdown_animation_fade et_secondary_nav_dropdown_animation_fade et_header_style_left et_pb_footer_columns4 et_pb_gutters3 et_right_sidebar et_divi_theme et-db et_minified_js et_minified_css">
	<div id="page-container">

					<div id="top-header">
			<div class="container clearfix">

			
				<div id="et-secondary-menu">
				<ul id="et-secondary-nav" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12186"><a>912.590.6268 &#8211; 912.283.2244</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12139"><a href="https://wjhnews.com/membership-account/membership-levels/"><span style="color: #ffffff;">SUBSCRIPTION DETAILS</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9183"><a href="https://wjhnews.com/wp-login.php?redirect_to=http%3A%2F%2Fxhz.b2d.myftpupload.com%2Fmembership-account%2Fmembership-checkout%2F%3Flevel%3D1"><span style="color: #ff0000;">ONLINE PAPER LOGIN</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12501"><a href="https://wjhnews.com/wp-login.php?action=logout">LOGOUT</a></li>
</ul>				</div> <!-- #et-secondary-menu -->

			</div> <!-- .container -->
		</div> <!-- #top-header -->
		
	
			<header id="main-header" data-height-onload="50">
			<div class="container clearfix et_menu_container">
							<div class="logo_container">
					<span class="logo_helper"></span>
					<a href="https://wjhnews.com/">
						<img src="https://wjhnews.com/wp-content/uploads/2018/11/WJHnews-logo-MULTI-200-158.png" alt="WJHnews" id="logo" data-height-percentage="100" />
					</a>
				</div>
							<div id="et-top-navigation" data-height="50" data-fixed-height="50">
											<nav id="top-menu-nav">
						<ul id="top-menu" class="nav"><li id="menu-item-7993" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-7993"><a href="https://wjhnews.com/">HOME</a></li>
<li id="menu-item-1225" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1225"><a href="https://wjhnews.com/obituaries/">local OBITUARIES</a></li>
<li id="menu-item-8597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8597"><a href="https://wjhnews.com/previous-papers/">PAPERS</a></li>
<li id="menu-item-8470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8470"><a href="https://wjhnews.com/advertising-details/">ADVERTISING</a></li>
<li id="menu-item-454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454"><a href="https://wjhnews.com/wjhnews/">ABOUT</a></li>
<li id="menu-item-1203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1203"><a href="https://wjhnews.com/contactdetails/">CONTACT</a></li>
<li id="menu-item-704" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-704"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/pages/Waycross-Journal-Herald/126051204117430"><p style="text-align: center;"><img class="alignnone size-full wp-image-1195" src="https://wjhnews.com/wp-content/uploads/2015/01/facebook15.png" alt="" width="15" height="15" /></p></a></li>
</ul>						</nav>
					
					
					
					
					<div id="et_mobile_nav_menu">
				<div class="mobile_nav closed">
					<span class="select_page">Select Page</span>
					<span class="mobile_menu_bar mobile_menu_bar_toggle"></span>
				</div>
			</div>				</div> <!-- #et-top-navigation -->
			</div> <!-- .container -->
			<div class="et_search_outer">
				<div class="container et_search_form_container">
					<form role="search" method="get" class="et-search-form" action="https://wjhnews.com/">
					<input type="search" class="et-search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:" />					</form>
					<span class="et_close_search_field"></span>
				</div>
			</div>
		</header> <!-- #main-header -->
			<div id="et-main-area">
	
<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div id="left-area">
											<article id="post-12546" class="et_pb_post post-12546 post type-post status-publish format-standard hentry category-obits pmpro-has-access">
											<div class="et_post_meta_wrapper">
							<h1 class="entry-title">February 5, 2020</h1>

						
												</div> <!-- .et_post_meta_wrapper -->
				
					<div class="entry-content">
					
<p><strong>Norman Allen Wymbs </strong><br>WAYCROSS — Norman Allen Wymbs, 90, of Waycross, passed away Friday, December 27, 2019, at his residence surrounded by his family. Born December 27, 1929, in Red Bank, New Jersey, he was a son of the late Edgar Allen and Margaret Lamberson Wymbs. He was a veteran, having served in the United States Navy. A Jersey boy with a dream to be a cowboy, Wymbs moved west to pursue those dreams. He was an adventurous soul who traveled by what means were available, mostly hitchhiked. He landed several ranch positions and supplemented his income with his other trade as a commercial painter. He missed his sweetheart Anne and returned to the East Coast. Married in 1954, the couple had two children over the next few years. Norman and the family returned to the west and had two more children and raised his family. Wymbs joined the Bisbee Fire Department in 1961. He became the Fire Chief for the City of Bisbee, Arizona in 1977 and retired in 1985 following 24 years of service. As a certified Fire Inspector, he also served as the City Fire Marshall from 1982-1996. In November 1984, he was honored with the exchange of shoulder patches of a fellow serviceman, a Captain of the Tokyo, Japan Fire Department. Following retirement, he served as a city councilman for the city of Bisbee from 1986 to 1990, receiving numerous certificates of appreciation for his dedication and leadership in the community. Wymbs also served as President of the Vehelst Recovery House in Bisbee. He was strategic in obtaining grants for projects he was passionate about. One close to his heart was the grant for the senior citizens building and parking lot and bus to transport the seniors on trips to nearby cities. He and Anne moved to Waycross in 2003 to be near his family due to health complications. Wymbs will always be remembered as the “Cowboy” who did it his way. His stories will be forever embedded in all the hearts and minds of those who knew him. In addition to his parents, he was preceded in death by his wife, Anne Tradelius Wymbs, and two sisters, Janet Bocchino and Helen Frable. Survivors include his two daughters, Nancy Wymbs, of Waycross, and Linda Marie Wymbs (Luke), of Indian, Alaska; two sons, Norman R. Wymbs, of Waycross, and Richard Wymbs (wife, Loretta), of Waycross; eight grandchildren, Aubrey Mulligan (husband, Jeremiah), of St. Augustine, Florida, Patrick Hillier (wife, Anne), of Tucson Arizona, Rojeana Wymbs, of Laughlin, Arizona, Frankie Ann Wymbs, of Phoenix, Arizona, Norma Jean Wymbs, of Ft. Mohave, Arizona, Zolia Stevens (husband, Adam), Christopher Wymbs (wife, Samantha), of Tucson, Arizona, Wayne Wymbs, of Tucson, Arizona; and 17 great-grandchildren; two great-great-grandchildren; his special friend, Ed Cane, of Waycross; and several special nieces, nephews, and other relatives. Per his wishes, no public service will be held. A private family gathering will take place at a later time at Parker Lake in Arizona, a place he held close to his heart due to his many memories of fishing and spend- ing time with his children, grandchildren and many friends. Sympathy may be expressed by signing online at www.hartfh.com. Hart Funeral Home of Blackshear was in charge of arrangements.</p>



<p><strong>John Holton ‘Johnnie’ Todd </strong><br>JACKSONVILLE, Fla. — John Holton “Johnnie” Todd, 82, of Jacksonville, Florida, passed away Saturday, December 28, 2019, in Jacksonville. He was born March 18, 1937, in Broxton in Coffee County. He grew up in Ware County and was a graduate of Wacona High School. He lived most of his adult life in Jacksonville and was employed as a meat market manager for Winn- Dixie for more than 30 years before retiring. He also drove a delivery truck until his health began to fail. Todd was preceded in death by his mother, Alene Cato Todd Fulford, his father, Sampie “Samp” Todd, step-father, Kenneth R. “Kennie” Fulford Sr., his sisters, JoAnn Todd and Mar- lene Todd Dowling, his mother-in-law, Bessie Bennett, and two brothers-in-law and a sister-in-law, Leon Bolden, and Billy and Barbara Bennett. Survivors include his wife, Jeanette Bennett Todd, Jacksonville, Fla.; a daughter, Cheryl Todd Hartle and son-in-law, William “Bill” Hartle, Jacksonville, Florida; stepson, Ronald Dicks, Jacksonville, Florida; a sister, Myra Todd Bolden, Blackshear; two brothers, Sampie Linton Todd (Georgia) and K.R. Fulford Jr. (Shirley), both of Waycross; a brother-in-law, Danny Dowling, Blackshear; and many nieces, nephews and other relatives. A graveside memorial service will be held at 2 p.m. Saturday, February 8, at the Greenlawn Cemetery in Ware County with Elder Jason Deal officiating. Memorialization is by cremation. The family will gather at 11:30 a.m. Saturday, February 8, for lunch at Captain Joe’s Restaurant, Plant Avenue, Waycross. They will receive friends at the home of Sam and Georgia Todd, 3912 Driggers Road, Waycross, following the service. Hardage-Giddens Funeral Home, Riverside Chapel, of Jacksonville, Florida, is in charge of arrangements.</p>



<p><strong>Dr. Sidney ‘Sid’ Clyde Bennett III </strong><br>CHARLOTTE, N.C. — Dr. Sidney “Sid” Clyde Bennett III, 84, went home to be with his heavenly father on Tuesday, January 28, 2020. The funeral was held Sunday, February 2, at Mount Holly United Methodist Church, 1996 Mount Holly Road, Rock Hill, South Carolina. Burial followed in the church cemetery. Visitation was held prior to the service in the church foyer. Bennett was born on June 21, 1935, in Swainsboro, Georgia, to the late Sidney Clyde Bennett Jr. and the late Effie McKinna Bennett. He was preceded in death by his wife of 43 years, Linda Young Bennett. He was a loving husband, father, and grandfather who will be greatly missed. He was a man who had a passion for learning. After graduating from Georgia Tech in 1958, Bennett began his career as an Engineer with Lockheed in Marietta, Georgia. He received his Masters in Economics, and eventually, he earned his Ph.D. in Marketing and a minor in Finance while teaching Engineering at the University of Alabama. He went on to teach Marketing at Saint Louis University, the University of Missouri at Rolla and Winthrop University. Before he retired, he continued his love of learning by taking Accounting courses and passing his CPA exam. Upon his wife’s passing, he became a grief counselor and mentor to other men who lost their wives to cancer. This group would affectionately become known as The Brothers. Before his illness, Bennett was an active member of Mount Holly United Methodist Church and enjoyed singing in the choir each week. He is survived by his four children, his son, David Bennett (Aimee), of Atlantic Beach, Florida; his three daughters, Debbie Green, of Charlotte, North Carolina, Kathy (Stan) Layden, of Nolensville, Tennessee, Karen Bennett, of Charlotte, North Carolina; his six grandchildren, Monica Bennett, Grant Bennett, Sarah (Dylan) Murray, Bennett Layden, Montgomery Green, and Rachel Green; his brother, William H. “Bill” (Leslie) Bennett, of Way- cross, Georgia; his niece, Lisa (Eric) Strickland, of Richmond Hill, Georgia. In lieu of flowers, the family requests donations are made to Hospice &amp; Community Care, P.O. Box 993, Rock Hill, South Carolina 29731, or Hospice and Palliative Care of Greater Charlotte, P.O. Box 470408, Charlotte, North Carolina 28247, or Mount Holly United Methodist Church, 1996 Mount Holly Road, Rock Hill, South Carolina 29730. Condolences may be offered at www.greenefuneralhome.net</p>



<p><strong>Marcus Kelly ‘Mark’ Tillman</strong> <br>WAYCROSS — Marcus Kelly “Mark” Tillman, loving husband, father, and son went home to be with his Heavenly Father Tuesday, January 28, 2020, at the age of 56. He was born on May 18, 1963, in Waycross. He was a native and life-long resident of Ware County. He attended Ware County High School and had attended classes at Coastal Pines Technical College. Mark was a former Correctional Officer with Ware State Prison and a truck driver. He was preceded in death by father, Marqus D. Tillman, maternal grandparents, John and Estelle Vining, and paternal grandparents, Marqus (Mock) and Eula Tillman. Survivors include his wife, Tammy Tillman, of Waycross; a son, Marqus Jimmy Tillman (wife, Sara), of Waynesville; a step-daughter, Nicole Lute (husband, Jason), of Piketon, Ohio; three grandchildren, Ed- ward Tillman and Kaleigh Gibson, of Waynesville, and Grayson Lute, of Piketon, Ohio; his mother, Jeanette V. Lee (step-father Jerry), of Waycross; a sister, Janie McQuaig, of Waycross; two brothers, Kevin Tillman (wife, Jackie), of Alma, and Keith Tillman (wife, Janet), of Waycross; an aunt, Gail Johns (husband, Gene), of Waycross; father-in-law, Thurman Waldren (mother-in-law, Patty Waldren), of Waverly, Ohio; sister-in-law, Kim Massie (husband, Mike), of Waverly, Ohio; brother-in-law, Wayne Waldren, of Waverly, Ohio; and numerous nieces, nephews, and other relatives. He was a member of Christ Church where he served as the music director. He had a tremendous love for music, anything with a good beat! He had a heart for Gospel music. Mark spent his life singing and playing drums and bass guitar. He started out playing drums in the Ware County High School marching band where he sat First Chair most of the time. He played and sang for a couple of local groups, “Chosen” and “Heaven’s Touch.” He was also a drummer for The Waycross Express and was the tenor singer for The Hinsons. As a child, Mark loved to go to Fernandina Beach on family vacations, jump on trampolines there, then come home and jump up and down on his grandparent&#8217;s bed saying “Funindina Beach.” He was a wonderful man who had many adventures in his life. Besides going to the beach, singing and play- ing music, he loved to take rides, play games, enjoyed good food, going fishing and helping his friends in any way he could, cheering on his Georgia Bulldogs and his little Shih Tzu, “Precious,” and his little buddy “Peanut.” Auto racing was huge in Mark’s life. From a little boy, he worked in his Uncle Wayne Vining’s garage. There he helped his Uncle Wayne build his race car, X-15. He followed go-kart racing and NASCAR where he rooted for Jeff Gordon to take that checkered flag. Mark believed in the power of God. Going to church and being present before the Lord was huge in Mark’s life. He loved his wife, Tammy, the love of his life, and they were so very happy together in his last days. The family requests that memorial donations be made to Music Funeral Home to help with funeral expenses. Memorial donations may be made by following the following link. https://fundafamily.com/donation.aspx. A memorial service was held at 6 p.m. Saturday, February 1, at Music Funeral Home with the Rev. Franklin Peacock, the Rev. Johnny Batten, and Brad Anderson officiating. Sympathy may be expressed by signing the online registry at www.musicfuner- alhome.com. Music Funeral Home was in charge of arrangements. </p>



<p><strong>Norma Murray Logan </strong><br>WAYCROSS — Norma Murray Logan, 89, passed away peacefully Wednesday, January 29, 2020, at Hospice House Satilla in Waycross. She was born in Los Angeles, California, but resided in Ware County for most of her life. She was a member of Sweetwater Baptist Church. Logan was preceded in death by her husband, Glynn A. Logan, her parents, Ray Emory Murray and Vera Bennett Murray Head, her stepfather, Lloyd Head, and her brother, Ray Edwin Murray. Survivors include three sons, Ronald G. Logan (Nancy), of Duluth, Georgia, Gary A. Logan, of Jacksonville, Florida, and Steven A. Logan, of Waycross; her daughter, Gail L. Brantley (Paul), of Saint Johns, Florida; two grandsons, Patrick G. Logan (Michele), of Buford, Georgia, and Brian A. Logan (Shannon), of Decatur, Georgia; six great-grandchildren, Lance A. Logan, Alexis L. Logan and Sara E. Logan of Buford, Georgia, and Sawyer A. Logan, Drew B. Logan and Jack P. Logan, of Decatur, Georgia; and her sister-in-law, Kay Murray, of Branford, Florida. A funeral will be held at 3 p.m. on Sunday, February 9, 2020, at the Music Funeral Home Chapel. Burial will follow in Greenlawn Cemetery. The family will receive friends beginning at 2 p.m. Sunday, February 9, at the funeral home. Sympathy may be expressed by signing the online registry at www.musicfuneralhome.com.</p>



<p><strong>James Andrew Thigpen Jr. </strong><br>WAYCROSS — James Andrew Thigpen Jr., 94, died Friday, January 31, 2020, at his residence after an extended illness. A native of Atkinson County, he served in the United States Army. He retired from Waycross Plumbing Company as a sheet metal mechanic, and he was a past deacon and current member of West Carswell Baptist Church. Thigpen was preceded in death by his parents, James Andrew Thigpen Sr. and Sarah Rebecca Burch Thigpen, his wife, the love of his life, Bernadette “Bunnie” McDuffie Thigpen, and several brothers and sisters. Survivors include seven children, Dannie Anderson (Ronald), Debbie Evans (Pence), Andy Thigpen (Debby), Mike Thigpen (Teresa), Lisa Howell (Jamie), Latrell Lewis (Curtis) and Michelle Elerson (Harvey); 13 grandchildren, Chris Bennett (Heather), Wiley Anderson (Lezley), Mark Lewis (Amy), Matthew Lewis, Amy Stuart (Scott), Buck Thigpen (Heather), Cuyler Howell (Lauren), Jed Thigpen (Kaitlyn), Beau Thigpen, Trey Elerson, Hailey Taylor (Derek), Rann Howell (Dani) and Sarah Elerson; 18 great-grandchildren, Madison MacDonald (Michael), Connor Bennett, Darrian Bennett, Chael Thigpen, Jayce Thigpen, Arie Howell, Jimmy Howell, Jackson Howell, Evan Stuart, Shannon Stuart, Brandon Stuart, Emilia Taylor, SallyAnn Lewis, Michael Lewis, Samantha Lewis, Fletcher Lewis, Damien Lewis, and Troy Lewis; and numerous nieces and nephews. A funeral was held at 2 p.m. Monday, February 3, at the Music Funeral Home Chapel. Burial was in Mt. Pleasant Baptist Church Cemetery in Atkinson County. The family received friends at the funeral home Monday beginning at 1 p.m. Sympathy may be expressed by signing the online registry at www.musicfuneralhome.com.</p>



<p><strong>Mary Lea Shipes Davis </strong><br>WAYCROSS — Mary Lea Davis, 98, passed away peacefully at Baptist Village Retirement Community, Sunday, February 2, 2020, just 18 days before her 99th birthday. A lifelong resident of Waycross, she was born on February 20, 1921. She slipped into heaven with her daughter and son-in-law and Dr. Bill Young at her side. Family friend Martha Johnson beautifully sang Amazing Grace as she entered heaven’s pearly gates. Mrs. Davis was preceded in death by her parents, Martha Harris Shipes and Collis L. Shipes Sr. She married William B. “Bunt” Davis on December 5, 1942. Her beloved husband died at the early age of 47 in 1963. Their son, Roger L. Davis, died in 2004. Mrs. Davis outlived all three of her siblings, a sister Betty Jo Shipes, and two brothers C.L. “Buddy” Shipes Jr. and Wesley E. “Gene” Shipes. Survivors include her daughter, Martha Brantley, and son-in-law, Ricky Brantley; grandchildren, Britt (wife, Mandy) Brantley and Brooke (husband, Steve) Jaramillo; great-grandchildren, Emmi Hamrick, Addison Brantley, Alexi Hamrick, Cannon Brantley; and step-great-grandsons, Alex and Blake Jaramillo, all of Valdosta; her sister-in-law, Judy Shipes, of Waycross; special nephews Stephen (wife, Kim) Shipes, of Greensboro, Georgia, and Dan (Robyn) Shipes, of Beverly Hills, Florida; and several other nieces and nephews. Lovingly called “Nana” by her grandchildren and great-grandchildren, they brought great joy to her life and she loved to hear all about their daily activities. Mrs. Davis was a member of Central Baptist Church for 90 years which made her the member who has the longest tenure at her church. At the young age of 8, she accepted Christ as her Savior and faithfully attended and supported her church until her health limited her active involvement. She was a member of the Mary Martha Sunday School Class and the Merrymakers. For many years, she enjoyed traveling with the Merrymakers seeing trips and enjoyed playing the ukulele in their musical ensemble. She was educated in the Waycross City School System and was a member of the 1938 graduating class of Waycross High School. Mrs. Davis will be fondly remembered as the office manager and receptionist for the late Dr. Walter E. Lee Jr. in his medical practice. She worked for Dr. Lee for 27 years from 1961 until her retirement in 1988. Active in the Wacona Elementary School PTA and Ware County High School PTA and both schools’ booster clubs, she held various offices and was a strong supporter of community endeavors. She was a volunteer in helping give commodities to the needy. Known for her quick wit and humor, Mrs. Davis brought smiles and laughter to those who knew her. She loved to read and listen to music. In the last five years of her life, she resided at Baptist Village where she enjoyed the Music Therapy Program and the various trivia game activities. Her favorite pastime was eating chocolate ice cream and she never hesitated to ask even visitors at the village to get her a cup of it. The family would like to thank the nurses, CNAs, administrative staff and entire Baptist Village for their kindness and care during her time there. Mrs. Davis experienced an ever-changing world during the 98 years of her life. Growing up during the Great Depression, living through World War II, and then losing her husband at an early age, she relied on her faith and trust in God and became a confident, independent and self-sufficient woman who met each challenge with courage and grace. In lieu of flowers, the family requests that contributions be made to the Building Fund of Sweat Memorial Baptist Church in her memory. A funeral will be held at the Music Funeral Home Chapel at 2 p.m. Wednesday, February 5. Visitation at the funeral home will begin at 1 p.m., one hour prior to the service. Burial will be at Oakland Cemetery in Waycross following the service. Sympathy may be expressed by signing the online registry at www.musicfuneralhome.com</p>



<p><strong>Alfred ‘Al’ Hutto <br></strong>HOMERVILLE — Alfred Burnell “Al” Hutto, 78, of Homerville, died Sunday, February 2, 2020, at Memorial Satilla Health in Waycross after an extended illness. He was born in Appling County to the late Issac A. Hutto and Iona Edwards Hutto. He graduated from Appling County High School. He lived in Blackshear most of his life where he owned and operated Hutto Construction and also owned a cabinet shop. He also lived in Columbus, Georgia, and Manor for several years and currently lived in Homerville. Hutto was a member of Manor Community Baptist Church and was born again in 2007. He loved boating and pulling his son water skiing, loved horses, and especially loved to cook for friends. In addition to his parents, he was preceded in death by his siblings, Fonida Thomas, Austin Hutto, James Hutto, Jack Hutto, Geraldine Hardee, Ron Hutto, and Quentin Hutto. Survivors include one son, Toby Hutto and his wife, Danielle, of Homerville; two grandchildren, Jesse and Coleman Hutto; friend, Betty Oliver, of Manor; numerous nieces, nephews and other relatives. A funeral will be held at 3 p.m. Wednesday, February 5, at Manor Community Baptist Church. Burial will follow in the Camp Branch Providence Cemetery. The family will receive friends beginning at 1 p.m. Wednesday at the church. Sympathy may be expressed online at www.milesodumfuneralhome.com. Miles-Odum Funeral Home is in charge of the arrangements</p>



<figure class="wp-block-image size-large"><img src="https://wjhnews.com/wp-content/uploads/2019/12/trans50.png" alt="" class="wp-image-12452"/></figure>
					</div> <!-- .entry-content -->
					<div class="et_post_meta_wrapper">
					<div class="et-single-post-ad">							<a href="https://wjhnews.com/advertising-details/"><img src="https://wjhnews.com/wp-content/uploads/2019/01/advertise-here-boxed.jpg" alt="468" class="foursixeight" /></a>
				</div> <!-- .et-single-post-ad -->					</div> <!-- .et_post_meta_wrapper -->
				</article> <!-- .et_pb_post -->

						</div> <!-- #left-area -->

				<div id="sidebar">
		<div id="facebook-likebox-7" class="et_pb_widget widget_facebook_likebox"><h4 class="widgettitle"><a href="https://www.facebook.com/wjhnews/">Join us on Facebook</a></h4>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/wjhnews/" data-width="500"  data-height="582" data-hide-cover="false" data-show-facepile="true" data-tabs="timeline">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/wjhnews/"><a href="https://www.facebook.com/wjhnews/">Join us on Facebook</a></blockquote></div>
		</div>
		</div> <!-- end .et_pb_widget -->	</div> <!-- end #sidebar -->
		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->


			<footer id="main-footer">
				
<div class="container">
    <div id="footer-widgets" class="clearfix">
		<div class="footer-widget"><div id="text-12" class="fwidget et_pb_widget widget_text">			<div class="textwidget"><p><a href="http://waycrosschamber.org" target="_blank" rel="noopener noreferrer"><img class="alignnone wp-image-11662 size-full" src="https://wjhnews.com/wp-content/uploads/2019/08/WJH-WWCchamber.jpg" alt="" width="600" height="600" /></a></p>
</div>
		</div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="text-13" class="fwidget et_pb_widget widget_text">			<div class="textwidget"><p><a href="http://okefenokeeheritagecenter.org" target="_blank" rel="noopener noreferrer"><img class="alignnone wp-image-7809 size-full" src="https://wjhnews.com/wp-content/uploads/2018/11/WJH-OHC.jpg" alt="" width="600" height="600" /></a></p>
</div>
		</div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="text-14" class="fwidget et_pb_widget widget_text">			<div class="textwidget"><p><a href="http://exchangeclubofwaycross.com" target="_blank" rel="noopener noreferrer"><img class="alignnone wp-image-7810 size-full" src="https://wjhnews.com/wp-content/uploads/2018/11/WJH-exchange.jpg" alt="" width="600" height="600" /></a></p>
</div>
		</div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="text-11" class="fwidget et_pb_widget widget_text">			<div class="textwidget"><p><a href="https://serva.com" target="_blank" rel="noopener noreferrer"><img class="alignnone wp-image-7844 size-full" src="https://wjhnews.com/wp-content/uploads/2019/01/WJH-ads-serva-hands.jpg" alt="" width="600" height="600" /></a></p>
</div>
		</div> <!-- end .fwidget --></div> <!-- end .footer-widget -->    </div> <!-- #footer-widgets -->
</div>    <!-- .container -->

		
				<div id="footer-bottom">
					<div class="container clearfix">
				<div id="footer-info"><span>mobile compatible website design, hosting &amp; seo by</span> <span><a title="however you look at it - look your best with serva" href="http://serva.com" target="_blank"><span>serva.com</span></a></span></div>					</div>	<!-- .container -->
				</div>
			</footer> <!-- #main-footer -->
		</div> <!-- #et-main-area -->


	</div> <!-- #page-container -->

	<!--www.crestaproject.com Social Button Floating Start--><div id="crestashareicon" class="cresta-share-icon  first_style "><div class="sbutton  facebook-cresta-share float" id="facebook-cresta"><a rel="nofollow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F&amp;t=February+5%2C+2020" title="Share on Facebook" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-facebook"></i></a></div><div class="sbutton  twitter-cresta-share float noCount noCountTwo noCountThree" id="twitter-cresta"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=February+5%2C+2020&amp;url=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F" title="Share on Twitter" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-twitter"></i></a></div><div class="sbutton  googleplus-cresta-share float" id="googleplus-cresta"><a rel="nofollow" href="https://plus.google.com/share?url=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F" title="Share on Google Plus" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-gplus"></i></a></div><div class="sbutton  pinterest-cresta-share float" id="pinterest-cresta"><a rel="nofollow" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwjhnews.com%2Ffebruary-5-2020%2F&amp;media=https://wjhnews.com/wp-content/plugins/cresta-social-share-counter/images/no-image-found.png&amp;description=February+5%2C+2020" title="Share on Pinterest" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-pinterest"></i></a></div><div class="sbutton  print-cresta-share float" id="print-cresta"><a rel="nofollow" href="#" title="Print this page" onclick="window.print();"><i class="cs c-icon-cresta-print"></i></a></div><div style="clear: both;"></div></div>

<!--www.crestaproject.com Social Button Floating End-->
		<!-- Memberships powered by Paid Memberships Pro v2.2.5.
 -->
	<script type='text/javascript' src='https://wjhnews.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1'></script>
<script type='text/javascript' src='https://wjhnews.com/wp-content/plugins/cresta-social-share-counter/js/jquery.cresta-social-effect.min.js?ver=2.8.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var DIVI = {"item_count":"%d Item","items_count":"%d Items"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/wjhnews.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/wjhnews.com\/wp-content\/themes\/Divi\/images","builder_images_uri":"https:\/\/wjhnews.com\/wp-content\/themes\/Divi\/includes\/builder\/images","et_frontend_nonce":"8b191e4cc6","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"900abf40ca","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"1","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"12546","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://wjhnews.com/wp-content/themes/Divi/js/custom.min.js?ver=4.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wjhnews.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://wjhnews.com/wp-content/themes/Divi/core/admin/js/common.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://wjhnews.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'82302702',post:'12546',tz:'-5',srv:'wjhnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '82302702', '12546' ]);
</script>
</body>
</html>
